Jump to >
Review Board 3.0.5 is out with lots of fixes

I know what you're thinking. "Another Review Board release? Didn't we just have one this week?"

We did, and it was pretty great, but not perfect. A regression with repository configuration slipped in and broke things, and we didn't want you to wait any longer for a fix.

We've also been busy fixing other bugs this week, and felt it was as good a time as any to get those into your hands. So here they are.

Fixes for repository settings

Some bad logic broke repository configuration, causing options to show up that shouldn't and others to not show up when they should. It was confusing, both for administrators and for Review Board when trying to sort out what was set.

Bitbucket Server was showing up as a hosting service option twice if Power Pack was enabled. It was pretty excited to even be considered.

Fixes for search settings

Trying to enable Elasticsearch support without having the right module installed was causing a not-so-friendly error. Now it causes a very friendly error, telling you exactly to do to install compatible Elasticsearch support.

It should also help clear up the confusion around versions. We require Elasticsearch 2.x (5.x or higher won't work) because the search framework we use is capped at that. That's... not ideal, and we're considering options here.

Fixes for API token policies

Crafting a custom API token policy and hitting Save now properly switches the displayed policy type to "Custom" instead of "Full Access."

While a reload would have fixed that, that was pretty misleading, and led to more problems than it solved (which was none — no problems were solved by that bug).

Fixes for some other things

  • The field used to select available avatar backends should no longer appear blank at times
  • Using the submit-as option when posting review requests no longer shows (harmless but annoying) errors when Active Directory is enabled
  • Logging extension media installation errors no longer triggers its own errors

As always, see the release notes for the full list of changes.