Jump to >
RBTools 0.5.6 released

We just released RBTools 0.5.6, which fixes several bugs with Perforce.

A couple of the new commands, such as rbt status, would crash when used with Perforce repositories. These have been fixed, and you should now be able to use rbt status, rbt diff, and others without any problems.

We also fixed a long-standing bug with matching Perforce repositories. In previous releases, if $P4PORT was pointing to a server where you had an active client, RBTools could end up matching that client's repository instead of the one in the current directory. For example, if running inside a Bazaar repository, or (in some releases) in a Git repository. That should no longer happen in this release.

There's also a fix restoring Python 2.4 compatibility in rbt setup-repo. While the 0.5.x releases support Python 2.4, 0.6.x will not. If you are running Python 2.4, we recommend upgrading.

See the release notes for the complete list of changes.