Jump to >
Django 1.3.2 compatibility issues with Python 2.4

Yesterday, we released Review Board 1.6.11, which required the new Django 1.3.2 security release. Unfortunately, as some users have noticed, Django 1.3.2 breaks Python 2.4 compatibility. We have filed a bug against Django, but in the meantime, if you're using Python 2.4, you may need to downgrade back to Django 1.3.1.

To downgrade, first locate the Django-1.3.2*.egg directory in your Python path. Delete that, and then install 1.3.1 by doing:

$ sudo easy_install Django==1.3.1

We are hoping this will be addressed soon, at which point we'll update our 1.6.11 package with a hotfix that requires the new version.