Hello everyone.

GitHub has recently announced that they will soon be removing their older version 1.0 and 2.0 APIs, in favor of the newer version 3 API. This is scheduled to take place on May 1st, 2012.

Some users have already noticed that they have removed the API Token field, meaning that new GitHub Private and Private Organization accounts can't be accessed by Review Board today. We are in contact with GitHub and I'm hoping we'll have a solution to that.

Review Board uses the version 2.0 API to fetch files from GitHub, meaning that any installations using GitHub will stop working on May 1st. We are hard at work on moving to the version 3.0 API, and will have an update as soon as we can verify things are working properly. This will be Review Board 1.6.6.

There will be some manual steps required to get your GitHub repositories working again in 1.6.6. It will involve editing the repository entry, re-selecting GitHub, and authorizing an account. This will fetch the new OAuth2 API tokens from GitHub. Once you've done this, your repository will work again.

Further details will be provided as soon as we have a release.

Review Board 1.5.x users will need to upgrade to 1.6.6 in order to use their GitHub repositories.

Please contact our mailing list if you have any questions or concerns.